summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSanto Cariotti <santo@dcariotti.me>2024-08-21 13:25:55 +0200
committerSanto Cariotti <santo@dcariotti.me>2024-08-21 13:25:55 +0200
commita92fb07d23fb2268a6f4e650c5cbd00ad993e760 (patch)
tree149f2d084b8fec0b5a2bc5364f5d9e3487c94971 /Cargo.toml
parent24388ba81515c57e812994fdb9147e6de7f3a5b6 (diff)
Add login
Fields sent are ``` { "query": "mutation Login($input: LoginCredentials!) { login(input: $input) { accessToken tokenType } }", "variables": { "input": { "email": "....", "password": "..." } } } ```
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 50f662d..31bc110 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,3 +18,7 @@ tower-http = { version = "0.5.2", features = ["trace", "compression-br", "propag
lazy_static = "1.5.0"
serde = { version = "1.0.208", features = ["derive"] }
tokio-postgres = "0.7.11"
+jsonwebtoken = "9.3.0"
+once_cell = "1.19.0"
+chrono = "0.4.38"
+sha256 = "1.5.0"