summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..cc0473d
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "cas"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+async-graphql = "7.0.7"
+async-graphql-axum = "7.0.7"
+axum = "0.7.5"
+config = "0.14.0"
+futures-util = "0.3.30"
+postgis = "0.9.0"
+postgres = "0.19.8"
+serde_json = "1.0.125"
+tokio = { version = "1.38.1", features = ["rt"] }
+tracing = "0.1.40"
+tracing-subscriber = { version = "0.3.18", features = ["env-filter"] }
+tower-http = { version = "0.5.2", features = ["trace", "compression-br", "propagate-header", "sensitive-headers"] }
+lazy_static = "1.5.0"
+serde = { version = "1.0.208", features = ["derive"] }