summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSanto Cariotti <santo@dcariotti.me>2021-01-27 18:47:26 +0100
committerSanto Cariotti <santo@dcariotti.me>2021-01-27 23:02:24 +0100
commit79db3b2e02f2482e93060eef2ca1db22092bfe15 (patch)
treeab981dbe6d2a3ea14d25c8f35a0f63b4f1c1f8d2 /CMakeLists.txt
parentca8385bcf05183b3f0d6a63a356af85c58402481 (diff)
conf: add cmakefile
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..c830847
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,8 @@
+cmake_minimum_required(VERSION 2.8.9)
+project(hmacsha256)
+
+include_directories(include)
+
+file(GLOB SOURCES "src/*.cc")
+
+add_executable(hmacsha256 ${SOURCES})