summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSanto Cariotti <santo@dcariotti.me>2021-01-28 21:42:35 +0100
committerSanto Cariotti <santo@dcariotti.me>2021-01-28 21:42:35 +0100
commitf4fd89c776c9dccecc661058d272c7b252f6e85c (patch)
treea1a7ea7f041bc3a1d033b6d257b2c534a31d694f /CMakeLists.txt
parent938bd7bbf0f617d44ed9659addca3a4879948551 (diff)
conf: add cmake for tests
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c830847..07e12fe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,6 +3,5 @@ project(hmacsha256)
include_directories(include)
-file(GLOB SOURCES "src/*.cc")
-
-add_executable(hmacsha256 ${SOURCES})
+add_subdirectory(src)
+add_subdirectory(tests)