summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorSanto Cariotti <santo@dcariotti.me>2021-01-28 21:42:35 +0100
committerSanto Cariotti <santo@dcariotti.me>2021-01-28 21:42:35 +0100
commitf4fd89c776c9dccecc661058d272c7b252f6e85c (patch)
treea1a7ea7f041bc3a1d033b6d257b2c534a31d694f /tests/CMakeLists.txt
parent938bd7bbf0f617d44ed9659addca3a4879948551 (diff)
conf: add cmake for tests
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 0000000..eac999a
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,6 @@
+include_directories(${PROJECT_SOURCE_DIR}/include)
+
+add_executable(test_sha256 test_sha256.cc ${PROJECT_SOURCE_DIR}/src/sha256.cc)
+
+enable_testing()
+add_test(test_sha256 test_sha256)