summaryrefslogtreecommitdiff
path: root/server/Cargo.toml
diff options
context:
space:
mode:
authorSanto Cariotti <santo@dcariotti.me>2022-11-21 08:43:07 +0100
committerSanto Cariotti <santo@dcariotti.me>2022-11-21 11:14:53 +0100
commit7d661b657bbc31062e90b1a9c2bd8666627c2e07 (patch)
treea2576da3ca2f548f8bc753e5e5e4d99c1bf88795 /server/Cargo.toml
parented6e98137754f168480e0700063b01f14dd4f240 (diff)
Add CORS rules
Diffstat (limited to 'server/Cargo.toml')
-rw-r--r--server/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/server/Cargo.toml b/server/Cargo.toml
index f5cf075..8bceb99 100644
--- a/server/Cargo.toml
+++ b/server/Cargo.toml
@@ -15,7 +15,7 @@ serde_json = "1.0"
tokio = { version = "1.20", features = ["full"] }
tracing = "0.1"
tracing-subscriber = { version = "0.3", features = ["env-filter"] }
-tower-http = { version = "0.3.4", features = ["trace", "compression-br", "propagate-header", "sensitive-headers"] }
+tower-http = { version = "0.3.4", features = ["trace", "cors", "compression-br", "propagate-header", "sensitive-headers"] }
sqlx = { version = "0.6", features = [ "runtime-tokio-rustls", "postgres" ] }
sha256 = "1.0.3"
validator = { version = "0.16.0", features = ["derive"] }