summaryrefslogtreecommitdiff
path: root/server/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'server/Cargo.toml')
-rw-r--r--server/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/server/Cargo.toml b/server/Cargo.toml
index dca788a..8527fdb 100644
--- a/server/Cargo.toml
+++ b/server/Cargo.toml
@@ -5,7 +5,9 @@ edition = "2021"
authors = ["Santo Cariotti <santo@dcariotti.me>"]
[dependencies]
+async-trait = "0.1"
axum = { version = "0.5.15", features = ["headers"] }
+http-body = "0.4.3"
jsonwebtoken = "8.1"
once_cell = "1.13"
serde = { version = "1.0", features = ["derive"] }
@@ -16,3 +18,4 @@ tracing-subscriber = { version = "0.3", features = ["env-filter"] }
tower-http = { version = "0.3.4", features = ["trace", "compression-br", "propagate-header", "sensitive-headers"] }
sqlx = { version = "0.6", features = [ "runtime-tokio-rustls", "postgres" ] }
sha256 = "1.0.3"
+validator = { version = "0.16.0", features = ["derive"] }